Training Videos Won't Play

None of the training videos in my app are playing. Also, the videos I have downloaded to my phone are not playing either. My phone is on the latest iOS version. I deleted the app and reinstalled it, but the problem persists.

After the update by Freeletics, everything works as it should.

Yes, we did not communicate it broadly, but this bug was indeed fixed recently.
It was only affecting a few users/devices/videos

Still not working. Downloade latest version on iPhone but no video to see what so ever.

Same issue here. Already tried to reinstall app - did not help.

iPhone 15 pro
iOs 17.2.1
FL App

Hey @mueller.lorsch :wave:t2:

Can you try deleting all of your downloaded videos and then see if you are able to either redownload those you want or see if they play for you?

You’ll find the option to delete them via the screen accessed by tapping on the settings icon in the top right hand corner of your ‘Profile’ tab. Just scroll down to ‘Manage videos’ and hit the ‘Delete all’ button.


Hi Ben. – this did not help. I deleted all. Yes, I can download the file. but it is not displayed.

Hi, I have the same issue here. Any updates?

I have the same problem.
Is there any solution about this issue?

i have the same problem for YEARS!! no matter what i do. sometimes it shows the video but most of the time i just get the message: “Couldn’t find any videos”, it’s very frustrating sometimes.
And by the way: I want also mention another problem:
When I select Dumbel and that I have all the weights… the app does not show me what weight to use for my workout.

The coach will suggest weights if a weighted journey is selected. Otherwise you should take the weight you are feeling comfortable with.