Adapt session ignores what I requested! Anyone else have this problem?

After a weekend of running I wanted to exclude legs from workout. So I did this, and got a workout with…
-high knees

All stuff that involves the legs. Poor really, couldn’t find any way of feeding back to Freeletics so posting here to see if anyone else has this issue. Thinking of leaving Freeletics and trying another app.

Hi @paul.hatcher1 , that’s very weird! I’ve never had this issue before. Have you tried hitting the “I want a different session” button as well to see if that changed anything?

1 Like

Yeah sometimes this is not working correctly so you have to play around a bit. It may help to play with quiet session or exclude legs in another session and see if that one is better

1 Like

Just want to add that the “Exclude” option isn’t designed to completely exclude these muscle areas, but rather to reduce the focus on these areas.

Looking at what you say you were offered, I’ll admit at first glance it’s easy to laugh at what I just wrote :see_no_evil: but it can still be that what you were assigned is less than what you otherwise would have been.

As an example, let’s say I’m assigned an Aphrodite (so that would include 150 squats) and want to reduce the focus on my upper & lower legs, it might be that instead I’m offered a part Aphrodite which will still consist of a lot of squats!

So, yes, sometimes you might need to combine 2 or more filters.

Often the best way to select an appropriate session is simply to choose a different one from the upcoming week.