GPS issues in Freeletics

Hi everyone :wave:t3:,

Since two days I’m having problems with my runnings training tracking.

It doesn’t track the distance at first, and suddenly I got like 800m (when in reality I’ve only done 500m) and my pace goes from 0 to 100. I have to use another app to track my performance, delete it in Freeletics and then enter it manually.


Reminder: 9 days without and an answer…

Hello, I am having same issue.
Some times the app is not tracking at all my distance and some times it jumps up to a crazy big ditance that there is no way I had done.
I am having this issue since weeks.
Today I have to do interval, which is the most annoying because I do not have any other app to follow up my intervals. So if today is not working again, then it is not valid my training

1 Like

I see there is no answer to the topic.
This magically improved after some time. But this past Sunday I had to to some interval and again the same issue. The app no was tracking correctly my distance and therefore my time. It was impossible to follow and to track with it.
Yeah sure I run always on the same track so I know the distance and I am using a second app and this was working but what I am suppose to do if the app tell me I have to run 200 m but this same app does not recognize I am doing it so it is not jumping to the rest time.
I have the feeling this error is happening every time more frequently and I am very disappointed at the service that I am paying.

And after months not even an answer on the topic…

1 Like

I also recognised this back in the days when I was running. The issue was my own phone.
Do you have power saving mode activated? This causes the GPS to be incorrect.
Another troublemaker is the running time of the mobile phone without rebooting.
I don’t know which Android version was affected, but there was a major change in Android SDK concerning GPS - so having an old Android version (10 or less) could also be a problem.

Hiii, thanks for your answer! I have the version 13 of Android. If you need further details I can send them.
About the saving battery thing I will check for it!
Nevertheless I run with freeletics + another app in parallel and I recognize the freeletics app has this problem with the GPS while the other app not :woman_shrugging:t2: