Can't synch Apple Watch training with iPhone


I worked out this morning with the Freeletics Apple Watch app. When I tried to “Send all the results to iPhone”, it didn’t work. I tried to reboot the watch AND the iPhone, but it’s still not working.

It might be due to the recent iPhone app update?

Is anyone else having the same issue?

Hey Nico,

We’re aware of a bug that is affecting the syncing of training from :watch: to the Training app.

Hopefully it is something that we will be able to resolve :+1:t2:


Hi Ben !
Is there any evolution after 3 weeks ?

I tried to sync iphone and apple watch, but the last step is the process “open your training session in the coach tab to sync them with your apple watch”, it’s really not clear.
Because when I open a session in the coach there is nothing on the phone or the watch to start a sync.

If I have to have the iPhone, I will have to use another app sadly I think :-/ Because when we have a watch it’s not to run with a phone…
Even if I just paid for a year.

Thank you in advance