Google Fit sync not working anymore

**Before reporting a potential bug, please first try uninstalling and reinstalling the app. **

In order for our technical engineers to reproduce and understand your problem as quickly as possible, we usually need answers to the following questions :point_down:t2:

-Description of every single step you made until you encountered this error-what did you do, what happened?

Since a few days, the sync with Google fit is not working anymore and my workouts doesn’t appear anymore in fit.
Freelectic app is linked with Google with appropriate authorisation

Could you please fix this ?

-What is the brand and model of your mobile device? (for example iPhone 13 / Galaxy S21)
Asus Zenfone 9

-Which operation system is your device using? (for example iOS 13 / Android 11)
Android 13

-Which version of the Freeletics app are you using? (for example 6.37)

-Which language is your app set to?

-Which timezone/state/country are you

-What date and time did this problem occur?

-Which browser you are using (if experiencing a bug on our website)?

Please also attach screenshots or a screen recording showing step by step how you encounter this problem :point_down:t2:

Be aware that it can take some time to reproduce and fix certain bugs, and so we do not normally give in-depth updates when resolving reported problems.


I am having the same issue as the original poster.
Tried first:

  • Removing access for Freeletics in my Google account settings
  • Restarting the phone
  • Gave Googe Fit permission
  • No success

Second attempt:

  • Re-installed Freeletics
  • Gave Google Fit permission (this time I have received a popup from Google to confirm the access)
  • No success

Phone: Google Pixel 6a
OS: Android 13
Freeletics: 23.18.0
Language: English
Location: Ireland, GMT +1
Problem Start: 21/05/23

Let me know if you need any other information.

@florian.esteves the same issue has been raised and answered here:

Hi, I can no longer find a section to open a support ticket or specific information for correct use. For some time now, the app has no longer kept track of running routes: it doesn’t count meters covered, speed, etc. I distinctly remember him keeping track of it before; the application on the phone has geolocation permissions. However, it so happens that in the section where the Google Fit panel was previously active, the wording now appears:

“Log in to Google Fit” with an exclamation mark
Going to see the further information on the matter, an alert appears
“Google Fit will be replaced by Health Connect. We are updating this feature»

Of course I also have Health Connect installed but still no way to get it working. Basically now the app cannot be used either in those “divinity” circuits that include races and sprints, or obviously for specific racing sessions.

This is only to describe the whole path that then led me to this forum in an attempt to better identify the problem.

Basically: isn’t there another way to use Freeletics for racing or sprinting? I mean do I have to count the meters traveled manually? Isn’t there another solution?

Personalize the simplification but usually I prefer to go to the point rather than getting lost in “one day there will be an update”, which at the moment does not pique my interest.

Thank you

Consuming a new API and refactoring existing code is sometimes very tricky and time consuming.
Something we end user sometimes forget.
I’m absolutely fine with “there will be an update but we’re not able to say when exactly” - but I also work as Software Developer and sometimes we also postpone tasks (for reasons) someone really wants to see implemented asap.

Any update on this matter?

I saw in the settings that the options for connecting with Google Fit and Google Health were deleted altogether, so what is the status?

I also feel really annoyed about not being able to sync my activities… and it will have an effect on my decision whether to prolong the use of Freeletics or switching to another app when my plan runs out.


It’s been recently replaced with Health Connect on the version 23.32.0.
I have the 23.33.0 and for me the sync is working and visible in Google Fit

1 Like

Thank you for your reply, that’s awesome to hear.

However the stable version in Google’s play store still is 23.31 with no connection present, so guess I have to wait a little while longer.
But that’s fine now that I know, that it is currently being worked on.


Hi Eric,
I had the same thing, latest stable version 23.31. No update available.
I am living in Ireland, so using this geo setting. When you change your account location to Germany or even have an account “based in” Germany, you can change the store. When I did this, the update became available for me.
Just updated to 23.32 and Heath Connect is showing now.
Best of luck!

The rollout on the Google Play store is gradually happening over the week.
The update should, therefore, be offered to you soon.
If you don’t want to wait, deleting the app and installing it new should do the trick.

I looked for this on various websites including youtube and solved it using to restart your mobile.